System Resource Management

Document revision 19-Nov-2002
This document applies to the MikroTik RouterOS v2.6

Overview

MikroTik RouterOS offers several features for monitoring and managing the system resources. Most of the system resource management tools are grouped under the /system menu. The user management, logging feature and some other system features are described in separate manuals.

Contents of the Manual

The following topics are covered in this manual:

System Resource Monitor

System Resource Monitor can be accessed under the /system resource menu:

[admin@MikroTik] system resource>
System resources
  monitor  Monitor CPU and memory usage
      irq  Interrupt Request usage information
       io  Input/Output ports usage information
    print  Print basic system resources information
      get  get value of property
[admin@MikroTik] system resource>

Basic System Resources

Use the print command to view the basic system resource status:

[admin@MikroTik] system resource> print
             uptime: 1d23h32m6s
        free-memory: 1112 kB
       total-memory: 29528 kB
                cpu: "WinChip"
           cpu-load: 0
     free-hdd-space: 6400 kB
    total-hdd-space: 46478 kB
[admin@MikroTik] system resource>

The argument values are self-explanatory.

System Resource Monitoring

The current system CPU usage and free memory can be viewed using the monitor command:

[admin@MikroTik] system resource> monitor
       cpu-used: 3
    free-memory: 1112

[admin@MikroTik] system resource>

The values for cpu usage and free memory are in percentage and megabytes, respectively.

IRQ and IO Usage Monitor

The IRQ and IO addresses can be viewed using the /irq print and io print commands:

[admin@MikroTik] system resource> irq print
Flags: U - unused
   IRQ OWNER
   1   keyboard
   2   APIC
 U 3
   4   sync1
   5   pc1
 U 6
 U 7
 U 8
 U 9
   10  ether2
   11  ether1
 U 12
   13  FPU
   14  IDE 1
[admin@MikroTik] system resource> io print
 PORT-RANGE        OWNER
 20-3F             APIC
 40-5F             timer
 60-6F             keyboard
 80-8F             DMA
 A0-BF             APIC
 C0-DF             DMA
 F0-FF             FPU
 1F0-1F7           IDE 1
 300-33F           pc1
 3C0-3DF           VGA
 3F6-3F6           IDE 1
 CF8-CFF           [PCI conf1]
 1000-100F         [Silicon Integrated Systems [SiS] 5513 [IDE]]
 1000-1007         IDE 1
 1008-100F         IDE 2
 6000-60FF         [Realtek Semiconductor Co., Ltd. RTL-8139]
 6000-60FF         [8139too]
 6100-61FF         [Realtek Semiconductor Co., Ltd. RTL-8139 (#2)]
 6100-61FF         [8139too]
[admin@MikroTik] system resource>

Reboot and Shutdown

The system reboot is required when upgrading or installing new software packages. The packages are installed during the system shutdown. Use the /system reboot command to reboot the router:

[admin@MikroTik] system> reboot
Reboot, yes? [y/N]: y
system will reboot shortly

Only users which are members of groups with reboot privileges can reboot the router or shutdown. The reboot process sends termination signal to all running processes, unmounts the file systems, and reboots the router.

Before turning the power off for the router, the system should be brought to halt using the /system shutdown command:

[admin@MikroTik] system> shutdown
Shutdown, yes? [y/N]: y
system will shutdown promptly

For most systems, it is necessary to wait approximately 30 seconds for a safe power down.

Configuration Reset

The reset command clears all configuration of the router and sets it to the default including the login name and password ('admin' and no password):

[admin@MikroTik] system> reset
Dangerous! Reset anyway? [y/N]:

The router is rebooted after the reset command.

Router Identity

The router identity is displayed before the command prompt. It is also used for DHCP client as 'host name' parameter when reporting it to the DHCP server. The router identity can be set using the /system identity set command:

[admin@MikroTik] system identity> print
    name: "MikroTik"
[admin@MikroTik] system identity> set name=Our_GW
[admin@Our_GW] system identity>

Date and Time Settings

The system Date and Time settings are managed under the /system clock menu:

[admin@MikroTik] system clock> print
         time: aug/09/2002 21:27:29
    time-zone: +03:00
[admin@MikroTik] system resource>

To set the system date and time use the set command:

[admin@MikroTik] system clock> set
Set new system date or time
       date  New system date [month/DD/YYYY]
       time  New system time [HH:MM:SS]
  time-zone  Local time zone
[admin@MikroTik] system clock> set
[adminMikroTik] system clock> set date=mar/26/2002 time=14:41:00 time-zone=+02:00
[admin@MikroTik] system clock> print
         time: mar/26/2002 16:41:12
    time-zone: +02:00
[admin@MikroTik] system clock>

Date and time settings become permanent and effect BIOS settings.

Configuration Change History

The history of system configuration changes is held until the next router shutdown. The invoked commands can be 'undone' using the /undo command. By invoking the command several times, the configuration changes can be 'undone' in reverse order they have been invoked. Use the /system history print command to see the list of performed actions:

[admin@MikroTik] system history> print
Flags: U - undoable, R - redoable
   ACTION                                   BY                 POLICY
 U new traffic monitor script added
 U DNS server configuration changed
 U device changed
 U marking rule moved                       admin
 U route changed
 U route added
 U routing table added
 U ipsec manual sa ex1 added
[admin@MikroTik] system history>
The list is printed with the newest actions at the top.

[MikroTik] system history> /undo
[admin@MikroTik] system history> print
Flags: U - undoable, R - redoable
   ACTION                                   BY                 POLICY
 R new traffic monitor script added
 U DNS server configuration changed
 U device changed
 U marking rule moved                       admin
 U route changed
 U route added
 U routing table added
 U ipsec manual sa ex1 added
[admin@MikroTik] system history>

Tip: If you accidentally removed some item, or set wrong argument value, just execute the /undo command to undo previously done action. The /redo would do the opposite - redo the previous undo action.


Copyright 1999-2002, MikroTik