MikroTik RouterOS V2.4 System Resource Management

Document revision 14-Oct-2001
This document applies to the MikroTik RouterOS V2.4

Overview

MikroTik RouterOS offers several features for monitoring and managing the system resources. Most of the system resource management tools are grouped under the /system menu. The user management, logging feature and some other system features are described in separate manuals.

Contents of the Manual

The following topics are covered in this manual:

System Resource Monitor

System Resource Monitor can be accessed under the /system resource menu:

[MikroTik] system resource>
      get  get value of property
       io  Input/Output ports usage information
      irq  Interrupt Request usage information
  monitor  Monitor CPU and memory usage
    print  Print basic system resources information
[MikroTik] system resource>

Basic System Resources

Use the print command to view the basic system resource status:

[MikroTik] system resource> print
           uptime: 14d8h49m58s
     total-memory: 28320
      free-memory: 7464
         cpu-type: ff/04
    cpu-frequency: 300
        hdd-total: 46474
         hdd-free: 25487
[MikroTik] system resource>

The argument values are self-explanatory.

System Resource Monitoring

The current system CPU usage and free memory can be viewed using the monitor command:

[MikroTik] system resource> monitor
       cpu-used: 1
    free-memory: 7464

[MikroTik] system resource>

The values for cpu usage and free memory are in percentage and megabytes, respectively.

IRQ and IO Usage Monitor

The IRQ and IO addresses can be viewed using the irq print and io print commands:

[MikroTik] system resource> irq print
 IRQ USED OWNER
 1   yes  keyboard
 2   yes  APIC
 3   no
 4   yes  serial port
 5   no
 6   no
 7   no
 8   no
 9   yes  ether1
 10  no
 11  yes  pc1
 12  no
 13  yes  FPU
 14  yes  IDE 1
[MikroTik] system resource> io print
 PORT-RANGE            OWNER
 20-3F                 APIC
 40-5F                 timer
 60-6F                 keyboard
 80-8F                 DMA
 A0-BF                 APIC
 C0-DF                 DMA
 F0-FF                 FPU
 1F0-1F7               IDE 1
 2F8-2FF               serial port
 3C0-3DF               VGA
 3F6-3F6               IDE 1
 3F8-3FF               serial port
 EE00-EEFF             ether1
 EF40-EF7F             pc1
 FC00-FC07             IDE 1
 FC08-FC0F             IDE 2
 FC10-FC7F             [CS5530]
[MikroTik] system resource>

Reboot and Shutdown

The system reboot is required when upgrading or installing new software packages. The packages are installed during the system shutdown. Use the reboot command to reboot the router:

[MikroTik] system> reboot
Reboot, yes? [y/N]: y
system will reboot shortly

Only users which are members of groups with reboot privileges can reboot the router or shutdown. The reboot process sends termination signal to all running processes, unmounts the file systems, and reboots the router.

Before turning the power off for the router, the system should be brought to halt using the halt command:

[MikroTik] system> shutdown
Shutdown, yes? [y/N]: y
system will shutdown promptly

For most systems, it is necessary to wait approximately 30 seconds for a safe power down.

Configuration Reset

The reset command clears all configuration of the router and sets it to the default including the login name and password ('admin' and no password):

[MikroTik] system>
Dangerous! Reset anyway? [y/N]:

The router is rebooted after the reset command.

Router Identity

The router identity is displayed before the command prompt. It is also used for DHCP client as 'host name' parameter when reporting it to the DHCP server. The router identity can be set using the /system identity set command:

[MikroTik] system identity> print
    name: MikroTik
[MikroTik] system identity> set name=Our_GW
[Our_GW] system identity>

Date and Time Settings

The system Date and Time settings are managed under the /system clock menu:

[MikroTik] system clock> print
    time: apr/26/2001 00:41:45
[MikroTik] system clock>

To set the system date and time use the set command:

[MikroTik] system clock> set
  date  New system date [month/DD/YYYY]
  time  New system time [HH:MM:SS]
[MikroTik] system clock> set date=oct/14/2001 time=20:25:00
[MikroTik] system clock> print
    time: oct/14/2001 20:25:03
[MikroTik] system clock>

Date and time settings become permanent and effect BIOS settings.

Configuration Change History

The history of system configuration changes is held until the next router shutdown. The invoked commands can be 'undone' using the /undo command. By invoking the command several times, the configuration changes can be 'undone' in reverse order they have been invoked. Use the /system history print command to see the list of performed actions:

[MikroTik] system history> print
 ACTION                                BY                                   TYPE
 address removed                       admin                                undo
 route added                           admin                                undo
 system identity changed               admin                                undo
 system time changed                   admin                                undo
[MikroTik] system history>
The list is printed with the newest actions at the top. Thus, in this example, the /undo command would 'undelete' the address which has been removed:

[MikroTik] system history> /undo
[MikroTik] system history> print
 ACTION                                BY                                   TYPE
 address removed                       admin                                redo
 route added                           admin                                undo
 system identity changed               admin                                undo
 system time changed                   admin                                undo
[MikroTik] system history>

Tip: If you accidentally removed some item, or set wrong argument value, just execute the /undo command to undo previously done action. The /redo would do the opposite - redo the previous undo action.


Copyright 1999-2001, MikroTik